
Elektrotechnik 2 Übungen
Laborübung 5: Magnetische Felder

P. Schönhuber

1 Einführung

Zahlreiche elektrotechnische Aufgabenstellungen lassen sich durch Abbildung auf
Schaltkreise mit konzentrierten Stromkreiselementen behandeln. In diesem Fall inter-
essieren lediglich die von außen messtechnisch zugänglichen Größen, wie z.B. anlie-
gende Spannung und durchfließender Strom. Eine Kenntnis der im Inneren der Strom-
kreiselemente vorliegenden Verhältnisse (z. B. Verteilung der elektrischen Stromdich-
te, der elektrischen Feldstärke oder auch des elektrischen Potenzials) ist nicht erfor-
derlich.

In besonderen Situationen können insbesondere parasitäre Effekte (z.B. Ohm’sche
Komponenten von Kapazitäten und Induktivitäten, Streufelder in Plattenkonden-
satoren und Magnetkreisen) in konzentrierten (Ersatz-)Stromkreiselementen zusam-
mengefasst werden. Auch dann gelingt eine Behandlung der gestellten Aufgabe ohne
Berücksichtigung der lokalen Feldverhältnisse.

Im Allgemeinen ist es jedoch erforderlich, die räumliche Verteilung der Feldgrößen
(magnetisches Vektorpotenzial, magnetische Flussdichte, magnetische Feldstärke) ge-
nau zu kennen. Sie stehen dann vor der Aufgabe, aus der Kenntnis der eingeprägten
Größen (Ströme bzw. Durchflutungen, Permanentmagnete) und der Geometrie des
Problems die Felder berechnen zu müssen. Sind diese bekannt, können daraus resul-
tierende Größen, die für die Aufgabenstellung von Interesse sind, abgeleitet werden:
beispielsweise die Permeanz bzw. Induktivität L einzelner Komponenten, die resul-
tierende Kraft auf einen Bauteil, der Maximalwert der im Feldgebiet gespeicherten
Energie, etc. An lokalen Größen ist vielfach der Ort der maximalen Flussdichte von
Interesse.

Manchmal kann die Aufgabenstellung auch umgekehrt sein, d.h. Sie kennen die
Maximalwerte, die nicht überschritten werden dürfen und suchen dazu die zulässigen
Anschlussgrößen.

Im Rahmen der Übung sollen Sie sich mit der prinzipiellen Vorgangsweise einer
derartigen Feldberechnung vertraut machen (Abschnitt 2). Anhand vorbereiteter Da-
teien lernen Sie die einzelnen Schritte der Feldberechnung nachvollziehbar kennen
(Abschnitt 3). In weiterer Folge des Übungsverlaufs sind Sie aufgefordert, die Pro-
blemstellung gezielt abzuändern und Feldberechnungen samt detaillierter Auswertung
der neu formulierten Aufgabenstellung vorzunehmen.
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2 Numerische Berechnung magnetischer Felder

2.1 Vorbereitende Schritte (,,Preprocessing”)

Festlegen der Geometrie

Im ersten Schritt ist es erforderlich, die Geometrie der Aufgabenstellung, d.h. die Ab-
messungen sämtlicher Gebiete des Feldraums (Außenabmessungen des Feldgebietes,
Elektroden, im Feldgebiet platzierte Körper, etc.) in einer Geometriedatei abzulegen.

Festlegen der Materialeigenschaften

Als nächstes müssen Sie für jedes Gebiet dessen charakterisierende Materialeigen-
schaften spezifizieren, d.h. Werte für die elektrische Leitfähigkeit, elektrische Permit-
tivität bzw. magnetische Permeabilität, aber auch ev. Werte der Volumsstromdichte
(Durchflutung von Spulen) in einer Datei ablegen.

Festlegen der Randbedingungen

Schließlich ist es erforderlich, die Randbedingungen anzugeben, also z.B. die vor-
gegebenen Werte von eingeprägten Flächenstromdichten (z.B. als Realisierung starr
magnetisierter Dauermagnete) bzw. die Randwerte des magnetischen Vektorpotenzi-
als festzulegen. Weiters müssen Sie dem Programm ein Abbruchkriterium mitteilen,
d.h. eine Schranke (z.B. für Fehlergrößen), bei deren Erreichen bzw. Unterschreiten
das Programm die (iterative) Berechnung abbricht.

Netzgenerierung für ein ebenes Feldproblem

Das gesamte Feldgebiet wird in kleine (zumeist dreieckige) Elemente zerlegt, in denen
dann in bestimmten Aufpunkten die Felder berechnet werden. Der Diskretisierung
(d.h. wie fein das Feldgebiet in Elemente zerlegt wird) kommt hohe Bedeutung für
eine effiziente Feldberechnung zu. Im einfachsten Fall wird das gesamte Feldgebiet in
gleich große Elemente zerlegt. Leistungsfähige Netzgeneratoren verwenden hingegen
adaptive Verfahren, d.h. in besonderen Bereichen (z.B. in der Nähe von Kanten,
Ecken, etc.) erfolgt eine sehr feine geometrische Auflösung, während in anderen Teilen
des Feldgebietes eine grobe Unterteilung genügt, was die Rechenzeit gering hält.

2.2 Feldberechnung im engeren Sinn (,,Processing”)

Die Feldberechnung im engeren Sinn stellt sich als Suche nach der nummerischen
Lösung eines Gleichungssystems dar. Bei der Verwendung von kommerziellen Feld-
berechnungspaketen kommen Sie üblicherweise mit dem Gleichungslöser nur über die
Angabe einiger weniger Parameter (z.B. maximale Anzahl von Durchläufen, Abbruch-
kriterium, Parameter zur Beeinflussung des Konvergenzverhaltens) in Kontakt, d.h.
Sie müssen festlegen, unter welchen Bedingungen das Programm ein Ergebnis als
Lösung akzeptiert und die Berechnung abbricht.
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2.3 Auswertung der Ergebnisse (,,Postprocessing”)

Darstellen der berechneten Feldgröße

Die Feldberechnung ist beendet, wenn für jedes Element des Netzes die Zahlenwerte
der berechneten Feldgröße in einer Datei eingetragen sind. Für die graphische Dar-
stellung dieser Lösungsdatei gibt es eine Vielzahl von Möglichkeiten, üblich sind für
skalare Größen (z.B. elektrisches oder magnetisches Skalarpotenzial) die Isolinien-
darstellung (Höhenschichtlinien), die Höhenschichtfarbdarstellung, dreidimensionale
,,Potenzialgebirge”, etc. Im Falle magnetischer Feldprobleme wird die Differential-
gleichung für das magnetische Vektorpotenzial ~A gelöst, dessen Charakter als Fluss-
potenzial eine Interpretation des Isolinienbildes des Vektorpotenzials unmittelbar als
Flussröhrenbild für die magnetische Flussdichte zulässt.

Darstellung des Verlaufs von Feldgrößen an speziellen Linien oder Punkten

Zusätzlich zur Gesamtdarstellung des Feldes interessieren manchmal die Werte an
speziellen Punkten oder entlang spezieller Linien durch das Feldgebiet.
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3 Das Programm FEMM

Im Rahmen der Übung verwenden Sie das frei verfügbare Programm FEMM FINI-
TE ELEMENT METHOD MAGNETICS (femm.berlios.de, Autor David Meeker
dmeeker@ieee.org), dessen Komponenten für Preprocessing, Processing und Post-
processing komfortabel vom Editorfenster femme aus gestartet werden können.

Abb.1 Das ,,About” - Fenster des Programms FEMM (Finite Element Method Magnetics), ein
Freeware-Paket des Autors David Meeker.

3.1 Der Editor femme

Starten Sie das Programm durch Doppelklick auf das Icon am Desktop. Das sich
öffnende Fenster beinhaltet bereits alle für die Feldberechnung erforderlichen Funk-
tionen.

• Öffnen Sie eine der vorbereiteten Geometriedateien (*.FEM) mittels File →
Open. Die Dateinamen beziehen sich auf die entsprechenden Beispielnummern
des Kap. 18 (Magnetische Kreise) in A.Prechtl, Grundlagen der Elektrotechnik,
Band 2.

• Punkte sind durch schwarze Kästchen, Ränder durch blaue Linien gekennzeich-
net. Grüne Symbole markieren die Eigenschaften des jeweiligen Bereichs.

• Mit View → Natural passen Sie die Darstellung an die jeweilige Fenstergröße an.
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3.2 Der Netzgenerator

• Sie können für jeden Bereich separat die geometrische Auflösung des Netzes
bestimmen:

– Schalten Sie mittels Operation → Block die Bereichsauswahl ein.

– Positionieren Sie den Cursor auf den gewählten Bereich.

– Rechter Mausklick: der angewählte Bereich wird durch ein rotes Kästchen
angezeigt.

– Durch Drücken der Leertaste öffnen Sie das Eigenschaftsfenster des ge-
wählten Bereichs (siehe Abb. 2).

– Über den Parameter Mesh Size können Sie die Auflösung des Netzes im
gewählten Bereich vorgeben.

– Alternativ dazu können Sie es mittels Auswahl von Let Triangle choose
Mesh Size dem Programm überlassen, eine adaptive Netzverfeinerung vor-
zunehmen.

• Mit Mesh → Create Mesh können Sie unmittelbar das Netz erzeugen.

• Das Programm zeigt unmittelbar das erzeugte Netz an (gelbe Linien) und gibt
die Anzahl der dafür benötigten Knoten aus.

• Obwohl das Programm keine Obergrenze für die Anzahl der Knoten beinhal-
tet, sollten Sie - um die Rechenzeiten in sinnvollen Grenzen zu erhalten - eine
Knotenanzahl < 15000 anstreben.

Abb.2 Eigenschaften des gewählten Bereichs: Die Netzauflösung kann entweder direkt vorgegeben
oder vom Programm automatisch bestimmt werden.
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3.3 Die Material- und Randwertdaten

Bevor Sie die Berechnung starten, müssen Sie den einzelnen Bereichen Material- bzw.
Randwertdaten zuordnen.

3.3.1 Materialdaten

• Überprüfen Sie zuerst, ob sämtliche für Ihre Aufgabenstellung benötigten Ma-
terialien in der Datenbank abgelegt sind.

– Öffnen Sie die Materialdatenbank mittels Properties → Materials Library
(vgl. Abb. 3).

– Im linken Pull-down Menü finden Sie sämtliche Materialien, die bereits in
der Programm-Datenbank abgelegt sind, im rechten Teil diejenigen, die
dem gerade geöffneten Modell zugeordnet wurden.

– Mittels der beiden Schaltflächen links unten können Sie die Materialkenn-
werte einsehen, bzw. neue in die Datenbank aufnehmen.

– Ordnen Sie alle erforderlichen Materialien dem Modell mittels der Schalt-
fläche Add selected material to model zu.

– Falls Sie neue Materialdaten über Create new entry in Library eingeben
wollen, müssen Sie die entsprechenden Werte im Formular (siehe Abb. 4)
angeben.

• Um einem Bereich ein bestimmtes Material zuzuordnen, kehren Sie wieder ins
Editorfenster zurück.

• Schalten Sie nochmals mittels Operation → Block die Bereichsauswahl ein.

• Positionieren Sie den Cursor wiederum auf den gewählten Bereich.

Abb.3 Die Materialdatenbank.
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Abb.4 Die Eingabeformular zur Erstellung neuer Material-Datenbankeinträge.

• Rechter Mausklick: der angewählte Bereich wird durch ein rotes Kästchen an-
gezeigt.

• Durch Drücken der Leertaste öffnen Sie das Eigenschaftsfenster des gewählten
Bereichs (siehe Abb. 1).

• Im Pull-down Menü Block type finden Sie alle dem Modell vorher zugeordneten
Materialien wieder.

• Wählen Sie das passende Material aus und schließen mit OK.

• Verfahren Sie so mit allen Volumsbereichen.

3.3.2 Randwertdaten

In bestimmten Problemstellungen ist es erforderlich, an Randflächen bestimmte Ver-
läufe des Vektorpotenzials bzw. der Flussdichte vorzugeben. So sind z.B. Flächen, an
denen kein magnetischer Fluss austritt (z.B. streuflussfreie Näherung!), durch kon-
stante Werte des Vektorpotenzials charakterisierbar. Andererseits lässt sich ein Homo-
genfeld durch eine lineare Abhängigkeit des Vektorpotenzials von der Ortskoordinate
angeben.

• Überlegen Sie, ob und welche Bedingungen bezüglich der Randwerte des Vek-
torpotenzials die von Ihnen behandelte Aufgabenstellung aufweist.
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Abb.5 Eigenschaften des gewählten Randelementes.

• Formulieren Sie diese Bedingungen für das Potenzial.

– Öffnen Sie mittels Properties → Boundary den Randwertdialog.

– Im Property Name Pull-down Menü finden Sie die ev. bereits angelegten
Randwerte, die Sie mit der Schaltfläche Modify Property betrachten bzw.
verändern können.

– Mit Add Property können Sie neue Werte anlegen.

– Schließen Sie mit OK ab und kehren zum Editorfenster zurück.

• Schalten Sie mit Operation → Segment die Randauswahl ein.

• Führen Sie den Cursor zu der Randlinie und wählen Sie sie mit rechtem Mausklick
an.

• Die ausgewählte Randlinie wechselt von blau auf rot.

• Drücken der Leertaste öffnet wiederum den Katalog der verfügbaren, zuvor
angelegten Randwerte (Abb. 5).

• Wählen Sie den passenden Wert und schließen Sie mit OK.

• Wiederholen Sie diese Prozedur für alle festzulegenden Randwerte.
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3.4 Der Gleichungslöser fkern

• Starten Sie mittels Analysis → Analyze den Gleichungslöser fkern.

• Das Programm zeigt Ihnen den Fortschritt der Berechnung laufend an (vgl.
Abb. 6).

Abb.6 Der Fortschritt der Berechnung sowie einige Kenndaten der behandelten Aufgabenstellung
werden angezeigt.

3.5 Das Visualisierungsmodul femmview

• Als letzter Punkt steht die Visualisierung der Ergebnisse aus.

• Starten Sie das Visualisierungsmodul mittels Analysis → View Results.

• Unmittelbar erscheint ein Isolinienbild des soeben berechneten Vektorpotenzials
(Abb. 7), das sich als Röhrendarstellung des magnetischen Flusses interpretieren
lässt.

• Mittels View → Contour Plot können Sie Anzahl und Schranken für die Poten-
ziallinien angeben.

• View → Point Props öffnet ein Fenster, das Ihnen die jeweiligen lokalen Werte
eines ausgewählten Feldpunktes (linker Mausklick) anzeigt.

• View → Density Plot öffnet ein Dialogfenster, auswählen von Show flux density
erzeugt eine Farbdarstellung des Flussdichtebetrages.
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Abb.7 Das Modul femmview zeigt das Ergebnis der Feldberechnung an.

3.6 Weitere Auswertemöglichkeiten

Sie haben die Möglichkeit, den Verlauf einer Größe (Potenzial, Feldstärkebetrag, Ener-
giedichte, etc.) bzw. deren Integral entlang frei wählbarer Geraden durch das Feldge-
biet zu betrachten:

• Schalten Sie zuerst mittels Operation → Contours den geeigneten Modus ein.

• Wählen Sie mit dem Cursor den Anfangspunkt aus, wobei mit linkem Mausklick
der nächstliegende vordefinierte Punkt, mit rechtem Mausklick die aktuelle Cur-
surposition ausgewählt wird.

• Fahren Sie den Endpunkt Ihrer Strecke an und klicken wiederum entweder rechts
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oder links. Die ausgewählte Strecke erscheint rot.

• Mit Plot X-Y öffnen Sie ein Dialogfenster und können auswählen, welchen Größenverlauf
Sie betrachten wollen.

• Drücken der Schaltfläche OK öffnet ein neues Diagramm mit dem Verlauf der
von Ihnen gewählten Feldgröße.

• Mit Integrate haben Sie die Möglichkeit, das Linienintegral über eine Feldgröße
entlang der von Ihnen vorgegebenen Strecke zu bilden.

3.7 Modifizieren der Aufgabenstellung

Um die Geometrie bzw. die Materialvorgaben Ihrer Aufgabenstellung zu modifizieren,
kehren Sie zum Editorfenster zurück.

• Definieren Sie zusätzliche Punkte mittels Operation→ Node und anschließendem
linken Mausklick.

• Erzeugen Sie neue Ränder durch Verbindung von Punkten: Operation → Seg-
ment und anschließende linke Mausklicks auf Anfangs- und Endpunkt.

• Operation → Block erzeugt Ihnen das grüne Eigenschaftssymbol, über das Sie
die Materialwerte dem Bereich zuordnen können (vgl. Abb. 2).


